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Summary

= Software:
* PLS_Toolbox “ for Matlab®

* Hands-on-pc laboratory
 Example #1: health and alcohol consumption
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Multivariate statistics software

= Matlab® (by MathWorks)

e Statistics toolbox o
;‘;'i'z: Copyright © 1996 Published by Elsevier Science Ltd

* PLS_Toolbox ° (by Eigenvector research Inc.)* T
o http://www.eigenvector.com/software/pls toolbox.htm Full Papers

- R The process chemometrics approach to process
monitoring and fault detection

[ fre e Barry M. Wise and Neal B. Gallagher

Eigenvector Research, 830 Wapato Lake Road, Manson, WA 98831, USA

. Pyt h O n Received in revised form 15 March 1996

Chemometrics, the application of mathematical and statistical methods to the analysis of chemical data,
PY f is finding ever widening applications in the chemical process environment. This article reviews the chemo-

re e metrics approach to chemical process monitoring and fault detection. These approaches rely on the for-
mation of a mathematical/statistical model that is based on historical process data. New process data can
then be compared with models of normal operation in order to detect a change in the system. Typical
modelling approaches rely on principal components analysis, partial least squares and a variety of other

chemometric methods. Applications where the ordered nature of the data is taken into account explicitly
. t e r S O t W a re are also beginning to see use. This article reviews the state-of-the-art of process chemometrics and current
eee

trends in research and applications. Copyright © 1996 Published by Elsevier Science Ltd

*Wise, B. M., and N. B. Gallagher (1996). The process
Stata : .
chemometrics approach to process monitoring and
e SAS fault detection. J. Process Control 6, 329-348.

JMP
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Matlab® codes

= Principal component analysis PCA™ on X = singular value decomposition on the
correlation of X

~

autoscaled X

* [U,S,V] = svd(cov(auto(X))) P XX
\/ X covariance  cov(X) = +—
* P=V; loadings P

o T=X*P; scoresT

X=t;pl;+toplr + ... + typl + E “ cov(X)p; =\ pi

*Jackson, J. E. (2003). A User’s Guide to Principal Components. Wiley-Interscience, Hoboken, N.J.

**Geladi, P., and B.R., Kowalski 1986. Partial least-squares regression: a tutorial. Anal. Chim. Acta 185, 1-17.
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PCA Matlab® code: NIPALS algorithm

function [T,P,E]=pca_profFacco (X)
T=[1;

P=[];

for n=1:min(min(size (X)), 20)

n
te=1;
tn=1;
if n==
X=X,
else
X=E;
end
m=1;
while (m<=1000) &&( (norm(te)/norm(tn))>10-12)
m
if m==1000
display('no convergence') ;
norm (te) /norm(tn)
else
if m==
xn=X(:,1);
tn=xn;
else
tn=tl;
end
pl=((tn'*X)/(tn'*tn))"';
pl=pl/norm(pl) ;
tl=(X*pl) / (pl'*pl) ;
te=tl-tn;
m=m+1;
end
end

T=horzcat (T, tl);
P=horzcat (P,pl) ;
E=X-tl*pl"';
end
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Example #1

Health and alcohol consumption




Health and alcohol consumption

" Available data:
e 10 observations (on the rows)
O nations

e 5variables (on the columns)
o wine, beer and liquor consumption, heart disease rate life expectation

liquor ine beer heart disease
consumption consumption consumption life expectancy [rate
WAELS WAELS L/year CELS 10° cases/year
7

France @ | 2.5 63.5 40.1 8 61.1
0.9 58.0 25.1 78 94.1
Switzerland = | 1.7 46.0 65.0 78 106.4
Australia | 1.2 15.7 102.1 78 173.0
1.5 12.2 100.0 77 199.7
usa 2.0 8.9 87.8 76 176.0
Russia | 3.8 2.7 17.1 69 373.6
1.0 1.7 140.0 73 283.7
Jlapan | 2.1 1.0 55.0 79 34.7
Mexico | 0.8 0.2 50.4 73 36.4

= Objective: exploratory analysis of the data
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Loading data in Matlab

. C d [\ MATLAB R2016b - academic use
.
ommana:.

. this is a table TN
* load wine

P Dl = fF
»i {9 Preferences & Community
) - - Dpe Variable ~ &Runandjlma u E SetP ath & @ @Req uest Support
New Open _ - ~ simuink L [ )
= FILE VARIABLE 5 ~ CODE _ SIMULINK ENVIRONMENT = ~ RESOURCES
Wl gt bl » D: ica Bologna_2017 » Lessonl
a taS e t Current Folder ® Command Window
Name- % 4 4\ Open X
°
. A I te r n a t I Ve Y |+  Bologna_2017 * Lesson1 v O Cercain Lessonl »r
° Organizza = Nuova cartella =- 1 @
sDocumenti " [ Nome ° Uliima modifica  Tipo
Y ® H % Boynload * Example_1_wine 01/07/201713:50  MATLAB D|
dalla user interrace
» Musica
& Vid
* select «Open
(( )) ~ Volume (D3) O
-
e the path for the dataset ne.mat s
W1l .

All MATLAB fil

Nome file: | . les E
% i 1l
cov (X)
close all
:
o shared in Moodle

ST
f

this is a double
precision dataset

8
Prof. Pierantonio Facco - Machine learning for process engineering



Initial data visualization

= Commands:
* bar3 (wine) or

= User interface:

e select the dataset
e «Plot» = «bar3»

bar3 (double (wine))

4\ MATLAB R2016b - academic use

- X
(2)|search Documentation L

clc
load wine
wine=double (wine) ;

bar3 (wine)
m-

7% FAVORITES
= A
| secion | vy hal Ll L ] PN et 1
C:‘*"Eﬁ » D: » Pierar plot area bar pie histogram contour surf mesh
Current Folder \
- MATLAB LINE PLOTS
Name - Value *
[Fwine ose 0l BB Y G kAl
plot semilogx semilogy loglog area
MATLAB STEM AND STAIR PLOTS TOP &
bar3 ‘More Hel p.
3-D bar graph
Stem stairs This MATLAB function draws a
three-dimensional bar chart, where each
MATLAB BAR PLOTS element in Y corresponds to one bar. TOP &
bar3(Y) *
L [l L3 b FY ]
Vwidth)
bar barh bar3 'style') histogram plotmatrix
b cSpec)
MATLAB SCATTER PLOTS ) TOP &
Command History | j o
e ] ERE|
S
load wine
spy plotmatrix
v
clc .
clear all @Plots for: wine  OAll plots Catalog

O Reuse Figure

“ New Figure

| OPTIONS
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Visual data exploration

data have different scales

\ 4

AUTOSCALING to give the same weight
to all the data (same importance to all
the variables)
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PCA in the PLS Toolbox

= Command:

* pcCa
4\ MATLAB R2016b - academic use - X
(2)]search Documentation L H
ﬁ D @ @ % New Variable & Analyze Code )i E {0} Preferences & g:,? (% Community
Find Files L J -
a Open Variable v & Run and Time Set Path 3 Request Support
New New Open || Compare Import  Save - Simulink  Layout - Add-Ons  Help )
<P EE » D: » Pierantonio Facco » Didattica » Bologna_2017 » Lesson1
Current Folder Workspace
Name- Value Size New to MATLAB? See resources for Getting Started.
| wine: 10x5 double 10x5 >> pea
Fe>> |
[4] Analysis - PCA (No Model) (2) - X
File Edit Preprocess Analysis Refine Tools Help FigBrowser ¥
i mCache : "general” DATE View (* = Not Available) X
Analysis Flowchart +8 Cache Settings and View
N . +=Demo Data
1. Load calibration data 01012017
2. Choose Preprocessing f28-Jun-2017
+20-Jun-2017
SSQ Table 3. Choose Cross-Validation f15-Jun-2017
Auto Select +05-Jun-2017
Percent Variance Captured by PCA Model (* = suggested) 4. Build Model £18-May-2017
+116-May-2017
75 vriance 76 variance .
freenn i e Review Model +27-Apr-2017
1 +119-Apr-2017
(@a e History @ 5. Choose Components +07-Apr-2017
[ R R A E e < N | |+o4-Apr-2017
cle 6. Review Scores +03-Apr-2017
clear all 7. Review Loadings
clc
. Use Model ¥
load wine
wine=double (wine) ; 8. Load Test Data
bar3 (wine) 9. Apply Model
clc
BE—
nu“
nalysis Help Pane: Neither data nor a model is currently loaded. Data can be loaded or imported ~
and/or a model can be loaded using the File menu
v
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Select PCA

Analysis - PCA (No Model) - [m] X

File Edit Preprocess Analysis Refine Tools Help FigBrowser

‘@] gﬂ. DECOMPOSITION
. Pq miiiispalkeompeneneals i X | [Ecache : "general" DATE View (* = Not Available) X
Purity - SIMPLISMA Analysis Flowchart +2 Cache Settings and View
MCR - Multivariate Curve Resolution 415 Demo Data
MPCA - Multiway PCA 1. Load calibration data - 01-Jul-2017
Batch Maturity A i +128-Jun-2017
H pply / Validate J i +128-Jun
CLUSTERING > 2. Choose Preprocessing 4120 Jun-2017
View: "
REGRESSION > 3. Choose Cross-Validation H15-Jun-2017
Number PCs: CLASSIFICATION N +/05-Jun-2017
STATISTICAL > 51 (* = suggested) 4. Build Model +18-May-2017
MULTI-WAY o _ 7?167May—2017
A FUSIER N ISEC RMSECV Review Model +127-Apr-2017
] Ii j +119-Apr-2017
Analysis Methods Help 5. Choose Components ‘ +07-Apr-2017
+104-Apr-2017
6. Review Scores "
7. Review Loadings ‘
Use Model "
8. Load Test Data
9. Apply Model
n
Analysis Help Pane: Neither data nor a model is currently loaded. Data can be loaded or imported A
and/or a model can be loaded using the File menu.
v
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Alternative method

= Command:
* browse ... and select PCA

4\ MATLAB R2016b - academic use - X

(2)[search Documentation pa
F New Variable &Analyze Code QPreferences ; @Community
b2 O gemew & a2 Ga O @b @

Open Variable v Run and Time Set Path Request Support
New New Ope || Compare  Import Save % & Simulink ~ Layout E ‘3

VARIABLE CODE SIMULINK ENVIRONMENT RESOURCES

<P EHEA » C: » Users ¥ faccpie82190 » Documents » MATLAB »

Current Folder ‘ Workspace (G}l Command Window

New to MATLAB? See resources

Name* Value Size PLS_Workspace Browser o X
>> browse
fx o> | File Edit View Analyze Help FigBrowser N
OF=a
Current Folder : C:\Users\faccpie82190\Documents\MATLAB v l@‘ ®
Analysis Tools Workspace
Topics (double click to open) Current Workspace Variables
—*FAVORITES Name Value Bytes

~~DataSet Editor

= Getting Started
MPCA_Principal Component Analysis
“Trend Tool

+XTOOLS

+2 DECOMPOSITION

+#REGRESSION

== CLUSTERING

CLASSIFICATION

-+ DESIGN OF EXPERIMENTS

CoTtnf,nﬁj _Hvis:coly ® +OBATCH ANALYSIS Model Cache
46.03/32.11 ol i TRANSFORM ®Cache : "general" DATE View (* = Not Available) A
Toad wine i ?OTHER +8 Cache Settings and View
. . -+ HELP +=Demo Data
wine (:,1) +R EIGENGUIDE ONLINE VIDEOS 01-Jul-2017
= char (wine (:,1) +128-Jun-2017
= char (wine(:,1)) +20-Jun-2017
(wine (1,:)) +115-Jun-2017
%-— 02/07/2017 11:18 --% . ||#05-Jun-2017 v
N| EErcenvecror Researcr mcorporaTeD | B

browse v
nm.|

Prof. Pierantonio Facco - Machine learning for process engineering 13



Data upload in the toolbox

Analysis - PCA (No Model) (2) X
File Edit Preprocess Analysis Refine Tools Help FigBrowser
Load Data >  Calibration
> i
Iayperi (et Sl A UCache : "general" DATE View (* = Not Available) X
New Data > Y-Block Analysis Flowchart +2 Cache Settings and View
Load Model Load X and Y +>Demo Data
Import Model Validation ‘ 1. Load calibration data +101-Jul-2017
Load Prediction X-Block Appl i +128-Jun-2017
_ pply / Validate ; un
Load Options Y-Block 2. Choose Preprocessing +120-Jun-2017
Save Data > Load X and Y . 3 Creese Cress VAR T +115-Jun-2017
Save Model Auto Select +105-Jun-2017
Export Model P Percent Variance Captured by PCA Model (* = suggested) 4. Build Model §187May7201 7
P +| - -
Export Predlctlons > 0 vdridrice 0 vdiidiice . 16 May 2017
Save Prediction Thione P Review Model +H27-Apr-2017
. +119-Apr-2017
Save Opt
Clave ptions N 5. Choose Components +07-Apr-2017
ear
+04-Apr-2017
Close 6. Review Scores £103-Apr-2017
7. Review Loadings
Use Model "
8. Load Test Data
9. Apply Model
n
Analysis Help Pane: Neither data nor a model is currently loaded. Data can be loaded or imported A
and/or a model can be loaded using the File menu.

Prof. Pierantonio Facco - Machine learning for process engineering
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Data upload in the toolbox

[# Analysis - PCA (No Model) - ] X
File Edit Preprocess Analysis Refine Tool = Load N
4 Loa - O X
[? OA
SAoNENRER
Select XBLOCK Data \L Cache : "general" DATE View (* = Not Available) \ﬁ
Look In: >> Workspace << N |+ 8 Cache Settings and View
It +>Demo Data
ems +01-Jul-2017
10x5 (double) J +128-Jun-2017
- = +20-Jun-2017
View: ssCrice fo enat J 15-Jun-2017
0 [ E
Number PCs: Auto Select EOS—Jun—201 7
Percent Varian J [218-May-2017
+16-May-2017
Cigerivdiue 0 vdridiice =
T e +127-Apr-2017
| I y +19-Apr-2017
J +07-Apr-2017
Item: wine ‘ +104-Apr-2017
L]
From File ‘ Refresh ‘ Help ‘ Load ‘ Cancel ‘ J
| L
Use Model
8. Load Test Data
9. Apply Model ‘
|}
Analysis Help Pane: Neither data nor a model is currently loaded. Data can be loaded or imported A
and/or a model can be loaded using the File menu.
v

Prof. Pierantonio Facco - Machine learning for process engineering 15



elect pretreatment

= Variable autoscaling
* mean centering
* scaling to unit variance

4] Analysis - PCA (No Model) - wine - ] X
File Edit Preprocess Analysis Refine Tools Help FigBrowser N
‘ﬁ” X-block > None
A 2|
YIbIOCk >. Mean CTnter . X|| [ECache : "general" DATE View (* = Not Available) x
Slutiey Altoscald | Analysis Flowchart t& Cache Settings and View
Load Preprocessing > Custom... +=Demo Data
Save Preprocessing > Set Current As Default ' 1. Load calibration data £01-Jul-2017
Plot Preprocessed Data > Apply / Validate 2. Choose Preprocessing +28-Jun-2017
- Save Preprocessed Data > ’ £20-Jun-2017
e I S5Q Table 3. Choose Cross-Validation H15-Jun-2017
Number PCs: ‘ P — £05-Jun-2017
Percent Variance Captured by PCA Model (* = suggested) 4. Build Model H18-May-2017
t16-May-2017
= 76 Variarce 76 Variance
Y oo ———— RMSEC RMSECV Review Model H27-Apr-2017
| I +19-Apr-2017
5. Choose Components £I07-Apr-2017
+04-Apr-2017
6. Review Scores i
7. Review Loadings
Use Model ¥
8. Load Test Data
9. Apply Model
n
[1 of 1] Caution: Number of splits will leave out a high A
percentage (33%) of the calibration data in each cycle. In small data sets, this may lead to
under-estimation of model performance.
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model building

[4 Analysis - PCA (No Model) - wine - m] X
File Edit Preprocess Analysis Refine Tools Help FigBrowser
) X | [mcache: "general" DATE View (* = Not Available) X
Analysis Flowchart +8 Cache Settings and View
1. Load calibration dat ‘ > Demo Datz
. Load calibration data H01-Jul-2017
Calibrate Apply / Validate ‘ . ‘ +128-Jun-2017
. +120-Jun-2017
View: L]
] SSQ Table ‘ 3. Choose Cross-Validation ‘ j15-Jun-2017
umber FCs: ‘ Auto Select £05-Jun-2017 i
Percent Variance Capturedfpy PCA Model (* = suggested) 4. Build Model ‘ +18-May-2017
-l.'-k | F— #16-May-2017
1 vdridrice 0 vdridrice .
<1l nere = e Review Model +27-Apr-2017
1 +119-Apr-2017
5. Choose Components ‘ +07-Apr-2017
) +04-Apr-2017
6. Review Scores £103-Apr-2017
7. Review Loadings
Use Model "
8. Load Test Data
9. Apply Model ‘
n
Data has been loaded but no model exists. Set the preprocessing and other options (from the A
Preprocess and Tools menus) and calibrate a model (click on "Model" icon in the status pane).
Data can be viewed and edited by clicking on the "X" and/or "Y" icons.
v
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envalues and explained variance

4] Analysis - PCA 1 PCs - wine - ] X
File Edit Preprocess Analysis Refine Tools Help FigBrowser
26 e Bl & AU R
=5/ K L 8 ANY X
' 1. Load calibration data ‘
Calibrate u Apply / Validate 2 EliEese Fresmmeser

View: $SQ Table g +15-Jun-2017
Number PCs:| 1 ’ +05-Jun-2017

A Cache : "general" DATE View (* = Not Available) X
+8 Cache Settings and View
= Demo Data

Analysis Flowchart

Auto Select

Percent Variance Captured by PCA Model (* = suggested) Build Model +18-May-2017
S ——— 16 May-2017

E oy e RMSEC RMSECV. Review Model +27-Apr-2017

1 [2.30e+00 46.03 46.03 0.697 1.451 current +19-Apr-2017
2 1.61e+00 32.11 78.14 0.4435 1.755 5. Choose Components ‘ 1+07-Apr-2017

3 5.84e-01 11.68 89.83 0.3026 3.692
4 4.22e-01 8.44 98.27 0.1247 21.65
5 8.64e-02 1.73 100.00 3.028e-15 21.65

6. Review Scores

1+04-Apr-2017
‘ 1+03-Apr-2017

7. Review Loadings

Use Model "

8. Load Test Data

9. Apply Model

explained cumulative explained

ariance (%) ariance (%)
46.03 46.03

| § L}
model has been calibrated from the data. Review the model using the toolbar button(s), save the A
model (File menu), or load test (validation) data (File menu). The number of components, . . .
preprocessing options, and other settings can also be modified to adjust the model. The data can
be viewed and edited from the Edit menu. v
11.68 89.82

0.42 8.44 98.27
0.09 1.73 100.00

e wN R
o
8!
0o
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Select the right number of PCs

K Analysis - PCA 1 PCs - wine - a X
le Edit Preprocess Analysis Refine Tools Help FigBrowser
1| OA [ =
J 55 o0 B 8|22 %
Rlot Eigenvalues/Cross-validation results Analysis Flowchart UCache : "general” DATE View (* = Not Available) x
P . nalysis Flowcha +8 Cache Settings and View
1. Load calibration dat ‘ +>Demo Data
. Load calibration data 01-Jul-2017
q d . i +128-Jun-
Calibrate Apply / Validate 2. Choose Preprocessing 28-Jun-2017
+20-Jun-2017
L °SQ Table 3. Choose Cross-Validation | |*15-un-2017
Pes: =T Auto Select +105-Jun-2017
~ ’ i +18-May-2017
i tyd bW gested) 4. Build Model ‘
click the~c/» on e 2017 |
Elyel diue 0 vdridrice 0 vdridiice .
P RMSEC__ RMSEC Review Model +27-Apr-2017
1 2.30e+00 46.03 46.03 0.697 1.451 current +19-Apr-2017
2 1.61e+00 32.11 78.14 0.4435 1.755 5. Choose Components +107-Apr-2017 H
3 5.84e-01 11.68 89.83 0.3026 3.692 . +04-Apr-2017
4 4.22e-01 8.44 98.27 0.1247 21.65 6. Review Scores +03-Apr-2017
5 8.64e-02 1.73 100.00 3.028e-15 21.65 . .
7. Review Loadings
Use Model "
8. Load Test Data
9. Apply Model
= H
model has been calibrated from the data. Review the model using the toolbar button(s), save the A
lodel (File menu), or load test (validation) data (File menu). The number of components,
leprocessing options, and other settings can also be modified to adjust the model. The data can
viewed and edited from the Edit menu. v [
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How to select the correct number of PCs

" Eigenvalue >1

= Scree test
* identify the “elbow” on the figure of the explained variance vs. number of PCs

= Cross validation
* identify the minimum of the RMSECV

_RMSECV explained variance

PrcislComponantNunber PragelCompanen Numoor

Valle, S., W. Li, W., S. J. Qin (1999). Selection of the Number of Principal Components: The Variance of the Reconstruction Error
Criterion with a Comparison to Other Methods. Ind. Eng. Chem. Res. 38, 4389-4401 50




oading plot

4] Analysis - PCA 2 PCs - wine - m] X

File Edit Preprocess Analysis Refine Tools Help FigBrowser

] B2 oo 2 8 120 R

B.Plot loads and variable statistics . Cache : "general" DATE View (* = Not Available) x|
X v v . Analysis Flowchart +8 Cache Settings and View
+>Demo Data

1. Load calibration data

wiodel l
alibiate u Apply / Validate

‘ +01-Jul-2017
+28-Jun-
2. Choose Preprocessing ‘ [*28-Jun-2017
+20-Jun-2017
View: m
3. Choose Cross-Validation ‘ jii15-Jun-2017
‘ +05-Jun-2017

+/18-May-2017
+116-May-2017

7%#@’% the green-curve 4. Build Model

gernvdiue e

fr_nn e S FivtSE RiviSEEY Review Model +27-Apr-2017
1 2.30e+00 46.03 46.03 0.697 1.451 +119-Apr-2017

2 [1.61e+00 32.11 78.14 0.4435 1.755 current 5. Choose Components ‘ +07-Apr-2017
84e-01 11.68 89.83 0.3026 3.692 +04-Apr-2017

01 8.44 98.27 0.1247 2165 6. Review Scores ‘ +103-Apr-2017

‘ 173 100.00 3.028e-15 2165 ‘

7. Review Loadings

Use Model "

o | Sloai=Data ‘

1. select the number of PCs (click twice)-» < ||

"
A model has been calibrated from the data. Review the model using the toolbar button(s), save the A
model (File menu), or load test (validation) data (File menu). The number of components,
preprocessing options, and other settings can also be modified to adjust the model. The data can
be viewed and edited from the Edit menu. v
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Variables correlation

" PC1 (46% explained variance)

* positive correlation

o variables 2-4: wine consumption — life
expectation

o variables 1-5: liguor consumption — heart
disease frequency
* anti-correlation

e 2-4/1-5: wine consumption(+ life
expectation) and heart disease
frequency (and liquor consumption)

=" PC2 (32%)
| variable  units * beer consumption seems to be
B liquor consumption L/year independent life expectation and heart
wine consumption L/year disease frequency and partially anti-
B beer consumption L/year correlated to wine and liquor
B jife expectation years consumption
B heart disease frequency 1/(100000 year)
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Score plot

4] Analysis - PCA 2 PCs - wine - O X
File Edit Preprocess Analysis Refine Tools Help FigBrowser N
8 o M2 & A2 %

B0t scores and sample statistics X | [Ecache : "general" DATE View (* = Not Available) X

Analysis Flowchart +8 Cache Settings and View
-+ Demo Data

‘ 101 Jul-2017

+128-Jun-2017

+20-Jun-2017

N I
- ]

Model '
Calibrate u Apply / Validate

1. Load calibration data

2. Choose Preprocessing

L o abe 3. Choose Cross-Validation ji15-Jun-2017
PCs: e Sl +/05-Jun-2017
Le -l iﬂig‘enm 4. Build Model ‘ #118-May-2017
fa€rcs e m uSEVm
Ciyerivdiy C I/OCVdIIdIILC eo vdridiice bOI E‘167May72017
e, ——— RAMSEC RMSEQ\L Review Model +127-Apr-2017
1 2.30e+00 46.03 46.03 0.697 1.451 +119-Apr-2017
2fister00 mam curent || 5. Choose Components | +07-Apr-2017
3 5.84e-01 11.68 89.83 0.3026 3.692 . +104-Apr-2017
4 42201 8.44 98.27 0.1247 21.65 6. Review Scores H103-Apr-2017
5 8.64e-02 1.73 100.00 3.028e-15 21.65 . A
€ ¢ 7. Review Loadings
Use Model
8. Load Test Data
9. Apply Model
|
A model has been calibrated from the data. Review the model using the toolbar button(s), save the A
model (File menu), or load test (validation) data (File menu). The number of components,
preprocessing options, and other settings can also be modified to adjust the model. The data can
be viewed and edited from the Edit menu. v
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Relations among observations

I " France (1) and Italy (2), are very
. i similar: high PC1
¢ R = Russia (7) is very dissimilar from
K other nations on both PC1 and
_________________________________________________________________ PC2
- = Czech Rep. (8) display the highest
- PCo
@France S/ .
Eg\?v||¥zerland ) | ®=USA (6), Japan and Mexico (10)
B Australia | are “average observations”
~HEUK S because they are close to the
;;jjsia origin
¥ czech Rep.
EJapan
Mexico
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Analysis - PCA 2 PCs - Wine

File Edit Preprocess Analysis Refine Tools Help FigBrowser

EIC WA WG IE

X
Analysis Flowchart

1. Load calibration data

2. Choose Preprocessing ‘

View: Soe
EAA R oosefCross-Validation
Number PCs: 2 A
{-elick the red.and blue arrows| .. ...
o e G RMSEC RMSECV Review Model
1 2.30e+00 46.03 46.03 0.697 1.49
2 current 5. Choose Components ‘
3 5.84e-01 11.68 89.83 0.3026 4121
4 422e-01 8.44 98.27 0.1247 6.173 6. Review Scores ‘
5 8.64e-02 1.73 100.00 3.028e-15 6.173

7. Review Loadings ‘

Use Model

8. Load Test Data ‘

9. Apply Model ‘

percentage (33%) of the calibration data in each cycle. In small data sets, this may lead to

under-estimation of model performance.

FH of 1] Caution: Number of splits will leave out a high

JCache :

PCA (svd) 4 PCs [Autoscale]
X4 [42,21]

PCA (svd) 4 PCs [Autoscale]
X3 [82,19]

PCA (svd) 4 PCs [Autoscale]
X2 [193,20]

X2 [193,20]

PCA (svd) 4 PCs [Autoscale]
X1[277,13]

PCA (svd) 3 PCs [Autoscale]
PCA (svd) 1 PCs [Autoscale]
X1[277,13]

PCA (svd) 3 PCs [Autoscale]
X1 [277,20]

PCA (svd) 1 PCs [Autoscale]
X1 [277,20]

"general" DATE View (* = Not Available)
+8 Cache Settings and View
t=Demo Data
t01-Jul-2017
t28-Jun-2017
t20-Jun-2017
+15-Jun-2017
t05-Jun-2017
t118-May-2017
t116-May-2017
t27-Apr-2017
t19-Apr-2017
t07-Apr-2017
rl04-Apr-2017
-103-Apr-2017

[+Hitem:
[+®jtem:
+Bitem:
[+®jtem:
[+Hitem:
[+®jtem:
[+®jtem:
+Bitem:
[+®item:
+Bitem:
[+Hitem:
[+®jtem:
[+Hjtem:
[+®jtem:
[+Hitem:
[+®item:

2017-04-03 16:22:03.56

2017-04-03 16:20:09.11

2017-04-03 16:17:49.46

2017-04-03 16:15:21.40

2017-04-03 16:15:16.83
2017-04-03 16:14:46.39

2017-04-03 13:04:11.94

2017-04-03 13:04:05.72

X
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Biplot: joint score and loading reading

Japan, Italy, Switzerland and France are

b"’,’IOtzscor,e pl°,t+ Ioad'"lg plof the nations with higher life expectation

pu * France and Italy have the highest wine
- A 1 consumption
= Russia has the lowest life expectation
- ioe 1 and the highest rate of heart disease
¢ and liquor consumption (but low wine
- o 6 1 and beer consumption)
______________________ £ & = Czech Rep. has the highest beer
R - consumption
| o ¢ onsumption [consumption [consumption |expectancy |disease rate
i A France | 2.5 63.5 40.1 78 61.1
] _ : ] 0.9 58.0 25.1 78 94.1
A" i & 1.7 46.0 65.0 78 106.4
i | | 1.2 15.7 102.1 78 173.0
C SSSSS i Grait britain 1.5 12.2 100.0 77 199.7
: 2.0 8.9 87.8 76 176.0
| | | | | | l | ! ! 3.8 2.7 17.1 69 373.6
’ zech Republic 1.0 1.7 140.0 73 283.7
1 40.03%) 2.1 1.0 55.0 79 34.7
0.8 0.2 50.4 73 36.4
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Save PCA model

[4 Analysis - PCA 2 PCs - Wine - X
File Edit Preprocess Analysis Refine Tools Help FigBrowser 3
Load Data B M)g‘ XJ
=2
Import Data —l X I-IECache : "general" DATE View (* = Not Available) X
New Data > AnalusisElawchact
Load Model Save _ 0 X
Import Model
Load Prediction
Load Options Save Model
Save Data >35Q Table Look In: ‘>> Workspace << v
Save Model Auto Select
Export Model > Percent Variance Captured by PCA Model (* = sugge; |tems
Export Predictions > o
Save Prediction : wine 10x5 (dataset) A
Save Options
Clewr > 1 h del
o . hame the mode
i .44 98.27 0.1247
5 8.64e-02 1.73 100.00 3.028e-15
v
ltem: PCAmodel l| ‘
To File ‘ Refresh ‘ Help ‘ Save ‘ Cancel ‘
"
A model has been calibrated from the data. Review the model using the toolbar button(s), save the A
model (File menu), or load test (validation) data (File menu). The number of components,
preprocessing options, and other settings can also be modified to adjust the model. The data can
be viewed and edited from the Edit menu. v 7 Cﬂ vp
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PCA model is saved in a data structure

-‘ MATLAB R2016b - academic use

o E— (2)] Search Documentation L

|

]
- B
———J

— YD B A Ll i, A
plot Plot as mult... Plot as mult... area bar scatter pie histogram contour surf mesh plotyy
SELECTION PLOTS
«pEH » C ¥ Users » faccpie82190 » Documents » MATLAB »
Current Folder ‘ Workspace ® | Command Window
Name = Value >> load wine

@] PCAmodell Ix1 evrimodel >> pea
ine 16x5 dataset S>>

[4] Open Mode — X

9 Load this model into the model-building interface, or extract and view the
raw model contents?

Load Model ‘ | View Raw Contents

1. PCA model structure in the
workspace (doyble-click it)

Command Histary @ {4 o ”
- 2. select “View raw content
scatter(1:10,E(:,1))
mean(E(:,1))
scatter(1:10,E(:,1))
box on;xlabel('observation'):;yla...
%-- 22/03/2019 08:26 ——-%
a=randn (100,1);
b=randn (100) ;

= a*b*a’

a'*b*a
%-- 22/03/2019 11:59 —-%
load wine

<

pca v
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Access details on PCA model

‘ MATLAB R2016b - academic use

- X
PLOTS S VARIABLE VIEW (2] search Documentation Pl
ree -
E&I E Open »  Rows Columns ] [ H; Transpose
Newfrom (4 Print + Insert Field Delete Field _  Sort ¥
VARIABLE SELECTION EDIT
oo 3 v C v Users ¥ faccpie82190 » Documents ¥ MATLAB » M
Current Folder Workspace @
Name = Value | model_content |
model_content x7 struct %1 struct with 15 fields
: 1x7 evrimodel Field ~ Value
wine 10x5 dataset
aﬂmodeltype ‘PCA’
@authcr ‘faccpie82190@MWFACCPIE-01"
E datasource Tx1 cell
[ date 22-Mar-2019'
L time [2019,3,22,12,0,48.2430]
[l info . loads field."
EE userdata ° i °
4. click detail
Eloads e C IC e g’
(] pred ik
Etsqs 2x1 cell
E ssqresiduals 2x1 cell
q
E description 3xT cell
El help Tx7 struct
< > .
maodelversion ‘8.2
Command History ®
scatter(1:10,E(:,3)) ~ H
-—
1. loads =scores + loadings
mean(E(:,1)) < >
scatter(l:10,E(:,1)) Command Window ®
box on;xlabel('cbservation');yla... >> load wine
%-- 22/03/2019 08:26 —-% >> pca 2 S S — Hotellin TZ
a=randn (100,1) ; fx >> . t q — g
b=randn (100) ;
— a*h*a'
a'*b*a
%-- 22/03/2019 11:59 —-% - o I
i —
3. ssqgresiduals =residuals
pca W
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Other details about PCA

4 MATLAB R2016b - academic use

VARIABLE VIEW

Search Documentation

S« Ha » C » Users » faccpie82190 » Documents » MATLAB » M
Current Folder \ Workspace | [ Variables - model_content.detail ® x
Name = Value model_content i“iJ model_content.detail
model_content 1x1 struct model_content.detail
g Tx1 evrimodel Field ~ oy
wine 10x5 dataset E hi
istory ~
E data 1 XE" I I d
i —— . ssq EI envalues + explained variance
HH ssq
eig {1
H rmsec [0.6970,0.4435,0.3026,0.1247,3.0277e-15]
rmsecv [1.4511,1.7551,3.6918,21.6468,21.6468]
E esterror Ox0 struct
E means Tx71 cell
E stds Tx7 cell
E reslim Tx7 cell
Etsqlim TxT cell
2 IIf= residuals limit
. , | [ eigsnr . res. = resiauais iimi
[l cv ‘vet'
Command History ® | FH split -
scatter(1:10,E(:,3)) & EBiter 1
scatter(1:10,E(:,1)) ol TI,,,,, R 517,12‘1?14:5,11213,4,5] v
mean(E(:,1)) < >
scatter(1:10,E(:,1)) Command Window \ B . 2 . . ®
. ' Sont') s . -—
b chilabel (‘chieniasion ) ilan o loaa wine 3. tsqglim = Hotelling T¢ limit
%-- 22/03/2019% 08:26 ——% >> pca
a=randn (100,1); Jx >>
b=randn(100):
— ath¥a!'
a'*b*a
%-- 22/03/2019 11:59 ——%
load wine
pca v
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Model details and flexibility

» The model is available in the Matlab® Workspace in a structure with the
assigned name

" A lot of useful information are stored in the structure:
* PC explained variance
e scores and loadings
* model and sample diagnostics
* confidence limits
e etc...

* The model building and processing is much faster writing and running Matlab®
code
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PCA with PLS Toolbox® and Matlab® commands

clear all
close all

clc

% load alcohol consumption dataset

load wine

% data visualization
X=double (wine) ;

bar3 (wine) ;xlabel ('variable') ;ylabel ('country') ;

% PCA with the PLS Toolbox
opca.display='off"';
opca.plots='none';
opca.preprocessing="'autoscale';

pcal=pca (X,2,o0pca) ;

% scores
T=pcal.loads{1l,1};

figure;scatter(T(:,1),T(:,2)) ;box on;xlabel ('PCl score') ;ylabel ('PC2 score')

% loadings
P=pcal.loads{2,1};

% PCA matrix reconstruction
Xhat=T*P';

Xa=auto (X) ;

% residuals

E=Xa-Xhat;

% eigenvalues and explained variance
lambda=pcal.detail.ssq(:,2);
2.3014/sum(lambda)
lambda./sum(lambda)
lambda./sum(lambda) *100

cumsum (lambda . /sum(lambda) *100)

% Q residuals

Q=sum(E."2,2);

% Hotelling T*2

T2=diag(T*inv (diag(lambda(1:2)))*T') ;

% singular value decomposition
[U,Lsvd,Psvd]=svd (cov (auto(X))) ;

Tsvd=Xa*Psvd;
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Today homework

= Replicate through commands what we did with the PLS_Toolbox graphic user
interface
* [PCAmodell]=pca (X, 2) ;
* [predict]=pca (Xnew, PCAmodell) ;

= Practice with command
* svd

= Extract all the mathematical entities:
* scores
* |loadings
* residuals
* eigenvalues
. etc...
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... per sempre a fianco a me!
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